It’s CRUCIAL you read this …

Or, The Data Loss Rollercoaster

So, I bought an mSATA SSD a year or so ago to go into a laptop I purchased that (obviously) had an mSATA port in it.  The manufacturer had elected to include a microscopic mSATA drive and to use it for cache acceleration only, but I wanted to get a big enough drive to toss the entire OS on it and have the laptop boot from it.  I did some research and at the time, the most cost effective drive for me was a Crucial m4 120GB mSATA SSD, which I got for something like $120 from Amazon.  Not a bad price.

I’ll divert here to complain about the laptop I have, which is nobody’s fault but my own, but I’m going to complain anyways.  I bought a Dell Inspiron 15R Special Edition for about $1,050 a little while ago — decently spec’d laptop, and surprisingly good build quality for both a Dell and their much maligned Inspiron line.  All in all, I’m pleased with the purchase — it was cheap, the device is well built, used pretty decent materials, etc.  I do have the problem where it’s got both an AMD 7730M and an Intel GPU in it, and of course only Dell’s (horrendously fucking outdated) drivers will properly support both GPUs and switching between them by application, but I digress.

Bringing it back to the main thread here, I bought an mSATA SSD to put into my laptop.  Once Amazon delivered my shiny new SSD, disassembly of the Inspiron had to occur.  I cannot express to you in words how poorly designed the internal of the Inspiron 15R is SOLELY from the perspective of someone trying to replace the mSATA drive.  I shit you not, by the time I had the mSATA drive exposed, there was not a single screw in the chassis or screen left.  It seriously was the absolute last piece of equipment in the entire laptop by the time it was free.  Every. Single. Piece. Other. Than. The. mSATA. Had. To. Be. Removed.

FUCK that was a pain in the ass.  I’m pretty good about shit like that too, and it still took me about 90 minutes to take everything apart, get the mSATA SSD put back in, then another 20-30 minutes to put it all back together again.

In short, Dell, I hate your hardware designer.

ANYWAY, so I replaced the tiny cache SSD with my 120GB Crucial M4 SSD, installed my OS, and was off and running.  Performance was spectacular as you’d expect from an SSD, all is right with the world.

Flash forward about 7-8 months — I’ve gotten a Surface Pro at this point (I’ll post about how much I fucking love that device some other time), and as such haven’t been using the laptop very much.  I go to turn it on without being plugged in and apparently it had been long enough that there was just enough battery left to turn it on, but not enough battery to do anything else.  Screen lights up, Dell logo, then battery kicks and machine cuts off.

This is where things start getting stupid.

I plug the laptop back in and turn it on and am greeted by a blue screen from Windows 8, effectively the Windows 8 equivalent of the “INACCESSIBLE_BOOT_DEVICE” BSOD.  I reboot and check in bios and it tells me “mSATA:  Not Installed”.  GODDAMNIT.  Thankfully, I only had my OS on that drive and all my data was safe, but I really didn’t want to open the machine back up to get that mSATA out to send back to Crucial.  Digging around in forums, I find that the Crucial M4 series of mSATA SSDs has a SERIOUS and glaring fault — if the SSD loses power unexpectedly, it will fail to be recognized by the BIOS again until you perform a lengthy power cycle (that they recommend involve physically unplugging the mSATA drive from power/data, which in my case WAS NOT A FUCKING OPTION).  So, per their instructions, I turn on the laptop and bring it into BIOS and let it sit for 20 minutes, after which I unplug the battery, power down the laptop and unplug the power cord from it for 30 seconds while holding the power button to ensure the entire main board fully discharged.  Power the machine back on and my SSD has magically reappeared, my system boots, all is good.  Following direction from Crucial support, I update the drive to the latest firmware (which is supposed to address the power loss / faux-brick behavior) with no issues and turn the laptop back off again.

Flash forward another 3 months and my Surface Pro was in another room and I was too lazy to go get it, so I powered on my laptop and decided it was time to upgrade it to Windows 8.1 as well.  Well, (and this is on me) I made the same mistake twice — I didn’t plug it into power, turned it on, it showed the Dell logo, immediately cut off, and as expected my Crucial M4 SSD was no longer visible to the BIOS.  CURSES.  Completed the 20 minute power cycle and got the drive back, booted into Windows, went to Crucial’s website and noted there was a new firmware, highly recommended update, it directly addresses this power loss / power cycle issue.  Downloaded the Windows firmware installer and ran it.

ERROR 0 WHILE UPDATING FIRMWARE

System stops.  SSD has disappeared while the OS is running, the entire system hard locks.  Reboot, SSD is gone from BIOS, INACCESSIBLE_BOOT_DEVICE BSOD.  Mother fucking god damnit.

Download Crucial’s linux .ISO and spend 15 minutes trying to turn it into a bootable USB drive before realizing that even though it’s 2013, I do still actually have a spindle of CD-Rs somewhere, spend 45s burning the stupid ISO and boot it —

No eligible SSD found.

GAH.  Fuck this stupid SSD.  I still really don’t want to take the fucking laptop apart again, so I’m willing to try anything to make it work.  I decide to give it one last power cycle to see if I can get the drive recognized in BIOS again and booting.  20 minutes later, and much to my surprise, the drive reappears.  I take the opportunity to boot off the ISO and attempt to flash the drive and am greeted with yet another error message:

SSD is already running the current version of firmware.

Let me get this straight — your poorly designed SSD (that crashes any time it loses power unexpectedly) crashed itself immediately following a firmware update (to the point that it errored out and took the entire running OS with it as it was dropped by BIOS and unresponsive), a firmware update that was designed solely to resolve the power loss / power cycle issue, and had to be power cycled in order to be brought back to working.  I’m not even going to get into the complete and utter bullshit oversight by a company who thinks that it’s OK for a drive to completely lose its mind when it loses power abruptly (I mean, has Crucial ever heard of a laptop before in their entire lives?)

So in closing, don’t buy a Crucial M4 SSD unless you want to play Six Flags over Your Data and spend time power cycling shit over and over again.  This drive will absolutely die on you, but the good news is that in most cases it dies, all it wants is a little attention to get back to booting.

Fuck you, Crucial.

Now go away.